Tag Archives: ASUS G73

ASUS G73 G73jh ATI 5870 GSOD Grey Screen of Death – FIX

One of the computers in our office is an ASUS G73jh which is a powerful laptop we use for testing sites and on-location visits to clients. We usually keep the very latest Windows 7 updates and ATI video card drivers (11.4) on the machine. Recently we noticed the machine locking up after a few minutes running 3D graphics. The only recovery is to hold down the power button and power cycle the computer. The issue was easily replicated using FURMARK or BURN IN TEST. After much research we determined this is the infamous GSOD or “Grey Screen of Death”.

This is what it looks like:

ATI 5870 GSOD Grey Screen of Death

ATI 5870 GSOD Grey Screen of Death

We tried everything to eliminate this issue that we could think of, even uninstalling the current video card drivers and going back to the ones on the ASUS site which are from 2009. Nothing would cure this issue, so we RMA’d the laptop back to ASUS. A week later we get the laptop back with “all tests passed, no problems” and the machine had been wiped back to the factory OS defaults for Windows 7 Home Premium.

At that point I reloaded the FURMARK and BURN IN TEST applications on the laptop, and guess what – it did not go into GSOD when running 3D. Now I immediately thought this is a driver issue with the video card, because I was trying to use the latest ATI Cataylist drivers, and this wiped laptop had a clean set of factory drivers. Not wanting to keep 2+ year old drivers on my laptop (which was purchased mid 2010), I set out to try and get to the bottom of the issue.

I found two forum sites with hundreds of pages of user posts on this exact issue. First one Here Second one here

The issue is that the video BIOS on the onboard 5870 video card is old and is not compatible with the latest ATI drivers, so what needs to happen is you have to do is flash update your video card and then install the latest video drivers from ATI (in my case they were version 11.4) from the ATI SITE here.

Here is the path I would recommend:

  1. download the modified, fixed video BIOS for the ATI 5870 from this post here
  2. Make sure your G73 has the latest system BIOS (current version is 213), if not, update your laptop to the latest system BIOS FIRST
  3. Extract the video BIOS files to a bootable USB stick and follow the directions on this page to flash the modified updated video bios
  4. At this point your G73 should have the latest video BIOS and system BIOS
  5. Boot the laptop. If you are not currently running the ATI Catalyst driver version 11.4, you should go and download the latest AMD Mobility Catalyst Driver from the ATI site. (current version is 11.4 as of today’s date).
  6. install the latest drivers and reboot, and your GSOD situation should be history.

Note: if you still experience some other form of glitching with your video card drivers on the G73, use this procedure to completely wipe the ATI drivers, then re-install the latest ones. Try using this procedure below to get a completely fresh install of the ATI drivers.


(Modified by The Amixa Web Guru. Original one by steviejones133)

  1. Uninstall the current AMD Mobility Catalyst Drivers by going to the control panel, uninstall programs and select everything. Remove. Do not use the EXPRESS removal. Use the one where you pick ALL the items to uninstall.
  2. Check in Device Manager that you are back to Standard VGA Drivers.
  3. If not back at VGA, uninstall/remove devices manually via device manager. This should get back to VGA.
  4. Reboot into safe mode (press F8 when you are at the BIOS to get to the Windows boot menu and pick SAFE MODE)
  5. Run Driver Sweeper in safe mode for Ati Display only (run as administrator by right clicking the icon – required) and CLEAN any ATI fragments.
  6. Quit Driver Sweeper.
  7. Re-run Driver Sweeper a second time (also as administrator), pick ATI again and let it scan once more to make sure all ATI fragments are gone
  8. Run CCleaner for both clean up and registry in safe mode.
  9. Repeat step 8.
  10. Restart normally to windows – the laptop will look bad due using only standard VGA drivers
  11. Re-run driver sweeper (admin)
  12. Re-run CCleaner
  13. At this point, all ATI driver fragments are gone.
  14. Go to the ATI site and download the latest AMD Mobility Catalyst Drivers
  15. Install the latest ATI drivers. Do not choose CUSTOM. Choose EXPRESS and let it complete.