Skip to content

Amixa Technical Blog

Classic ASP file upload limit of 200kb in IIS 7

During the process of migrating a site to IIS 7 we came across an issue with Classic ASP file uploads throwing 500 errors when larger than 200kb. There is an EASY fix for this.

In IIS 7, click your site and expand it then click the ASP icon.

Expand the Limits Properties icon, and change the value in the “Maximum Requesting Entity Body Limit” to a value larger than 200000 (which is about 200kb). 2000000 would be roughly 2mb, 20000000 would be 20mb.

Click the APPLY button. That’s it!

13 comments

  1. I made bunch of files of different sizes to figure out that 200kB is the limit.
    Thank you so much for showing how to change that!

  2. thanks, you saved me a fortune !

    I just migrated now in 2016 and had the same problem, now quickly solved

  3. Thank you, very very helpful, and just in time! I migrated a whole ASP site to Windows Server 2008, IIS 7, and the “500 error” always showed up when I was trying to upload a document through the site.

  4. Thank you very much. I was stuck on maximum file upload size issue for a couple of days. This solution worked perfectly.

  5. hi thanks for sharing this infomation please tell me is it necessary to restart application from IIS after changing Maximum Requesting Entity Body Limit?

Leave a Comment

Your email address will not be published. Required fields are marked *

Comments are reviewed before publication.

Protected by Cloudflare Turnstile. All comments are reviewed before publication.